Loading...
 
ESA > Join & Share > Forums > Toolbox Forum > Upgrade Toolbox from 6.0 to 7.1

Toolbox Forum

Help

Show posts:
Jump to forum:

Upgrade Toolbox from 6.0 to 7.1

Hello:

I'm trying to upgrade Toolbox version but I'm finding several issues and problems:

- Service descriptor from 6.0 is not valid at last version. I've got a Tomcat error page when I try to load it

- First script gives an error at next line:

setVariable name="fileURL1"

xPath
xmlRequest/
string
/:sendOrderInputMsg/:sendOrderInput/:fileURL1
/string
/xPath
/setVariable


At version 6.0 there wasn't any error.
- When I try to create my service, I specified SSE 1.6 as interface but next, all the SSE schemas seem to be loaded and I don't know how to specify my service schema. How can I unselect schemas not used?

Thanks in advance

Maria José


Re: Upgrade Toolbox from 6.0 to 7.1

Hi Maria.

I've had the same problem and reported it here a few months ago. At the time it seemed that it was a javascript problem when displaying the list of accounts (as you mention, they are created anyway).

We are at the moment starting a final testing activity of the TOOLBOX 8.0 and we will take care to see if this is fixed on that version.

Paulo


Re: Re: Upgrade Toolbox from 6.0 to 7.1

Hello Paulo:

Thanks for your reply. Then we hope for the new version of Toolbox. Do you know when the release will be available?

Thanks

Maria Jose


Re: Re: Re: Upgrade Toolbox from 6.0 to 7.1

Hello Maria Jose.

A patch for this issue is available. See http://wiki.services.eoportal.org/tiki-view_forum_thread.php?comments_parentId=550&forumId=3 .

This fix will also be on version 8.0 of the TOOLBOX. There is no foreseen release date for it, we are still testing.

Paulo



Re: Upgrade Toolbox from 6.0 to 7.1

No, I can't see any account.

However, I can see the created accounts at the properties file which is located at C:\Program Files (x86)\Apache Software Foundation\Apache Tomcat 6.0.18\webapps\TOOLBOX\WEB-INF\FTPServer\res\conf\user.properties

Any idea?

Thanks



Re: Upgrade Toolbox from 6.0 to 7.1

Hello Maria José,

the FTP should be listed. Can you see the admin account (created by default) or the list is empty?
Regards,
Toolbox Support Team



> Hello:
>
> I'm trying to upgrade Toolbox version but I'm finding several issues and problems:
>
> - Service descriptor from 6.0 is not valid at last version. I've got a Tomcat error page when I try to load it
>
> - First script gives an error at next line:

>
setVariable name="fileURL1"

> xPath
> xmlRequest/
> string
> /:sendOrderInputMsg/:sendOrderInput/:fileURL1
> /string
> /xPath
> /setVariable

>

>
> At version 6.0 there wasn't any error.
> - When I try to create my service, I specified SSE 1.6 as interface but next, all the SSE schemas seem to be loaded and I don't know how to specify my service schema. How can I unselect schemas not used?
>
> Thanks in advance
>
> Maria José



Re: Upgrade Toolbox from 6.0 to 7.1

Hello Maria,

in order to upgrade your service you need to export it from TOOLBOX 6.0, import into the TOOLBOX Development Environment through the specific import wizard and then publish in the new Toolbox 7.1.
Regarding the scripting snippet you are probably missing the namespaces in the xPath tag and into the xpath string. You need to specify all namespaces used in the xpath string otherwise you should get improper values or code should raise exceptions.
Regards,
Toolbox Support

> Hello:
>
> I'm trying to upgrade Toolbox version but I'm finding several issues and problems:
>
> - Service descriptor from 6.0 is not valid at last version. I've got a Tomcat error page when I try to load it
>
> - First script gives an error at next line:

>
setVariable name="fileURL1"

> xPath
> xmlRequest/
> string
> /:sendOrderInputMsg/:sendOrderInput/:fileURL1
> /string
> /xPath
> /setVariable

>

>
> At version 6.0 there wasn't any error.
> - When I try to create my service, I specified SSE 1.6 as interface but next, all the SSE schemas seem to be loaded and I don't know how to specify my service schema. How can I unselect schemas not used?
>
> Thanks in advance
>
> Maria José


Re: Re: Upgrade Toolbox from 6.0 to 7.1

Hello:

Thanks for your fast answer. I've solved this issue but I find something related with the FTP accounts.

When I've tried to create a new account, this is created but nothing appears when I select "view FTP accounts". I've checked that accounts are succesfully created and generated but I can't see them. Is it necessary to change any parameter?

Thanks in advance

Maria José



Show posts:
Jump to forum: