Loading...
 
ESA > Join & Share > Forums > SSE Forum > BPEL console only works with MS-ie

SSE Forum

Help

Show posts:
Jump to forum:

BPEL console only works with MS-ie

Would it be possible to request that the BPEL console works with an alternate browser, for example firefox. The present restriction to MS-ie currently causes an almost complete loss of functionalitiy for me: due to security holes in MS-ie, my organisation has turned off active scripting in all Microsoft browsers for the time being. This means that the BPEL console loses almost all functionality, as it relies on microsoft-prorietary active scripting in the microsoft browser. With various other technologies available, an alternative can sure be found? I would not be surprised if other security problems do not crop up in the microsoft-browser in the future.
In any case, as it is now, I cannot use the console to for exmaple mark a workflow as 'default'.


Re: BPEL console only works with MS-ie

Hello again.

We have some good news:

- First of all, we've installed a patch on all SSE Portals which implements a quick workaround that makes the BPEL Console work on IE7 and above! Nothing can be done for Firefox at the moment, but this is already an improvement.

- We are also making some progress regarding the planning of the migration from BPEL 10.1.2 to 10.1.3. It will be complex, but we are actively discussing it.

Paulo



Re: BPEL console only works with MS-ie

Thanks for the update. The issue is not urgent for us at the moment, since recent upgrades to ms-ie and our security policy once again allow full access to the BPEL with ms-ie, and all required functionality is again accessible without problems.
- Milan.



Re: BPEL console only works with MS-ie

Hello all.

We are well aware of this very important limitation, which in the past two weeks, due to the critical vulnerabilities found in IE 6, has become even more a case for concern.

Unfortunately (or maybe not) this limitation is not of the SSE itself but rather of the Oracle BPEL PM version that it uses currently. It's a third-party COTS.

I know that there's a more recent version of the SSE in the making that uses the Oracle BPEL PM 10.1.3 family and with this there are no problems with Firefox and newer versions of IE. I don't think we will be able to migrate to this in the very short term, but I will try to get a date which hopefully is not a long time away in the future.

Let me know also if you need help running multiple versions of IE side-by-side. We have a couple of tips for this, as other people have run into this problem (because using Windows Automatic Updates, you end up with IE 8 only).

Paulo

P.S.: IE 6 is still the ESA corporate browser (!)


Re: BPEL console only works with MS-ie

Ok thanks for the info. I think we'll find a short-term workaround and hopefully within a few weeks MS-ie will be patched, but any information on an upgrade date is appreciated.

Re: Re: BPEL console only works with MS-ie

Some more info:

- The BPEL PM 10.1.3 Console works at least with Firefox 3.0, so it should work with any modern browser.

- It is very complex to migrate from BPEL PM 10.1.2 to 10.1.3 and we are still analysing the feasibility and risks of this operation. One of the main difficulties is backwards-compatibility, not only in terms of the existing workflows but also in terms of the APIs that the current SSE uses to communicate with the BPEL PM. Another problem is that the BPEL PM 10.1.3 relies on more recent infrastructure software that is incompatible with the current SSE (so, the latter would also need to be changed).

- We are also looking for a complementary or alternative short-term solution that allows keeping the software (SSE, BPEL PM) more or less as it is but having the BPEL Console working in more recent browsers.

Paulo



Re: BPEL console only works with MS-ie

I agree with Milan, this would be very important! At least Firefox. Plus higher versions of IE too!


Show posts:
Jump to forum: