Loading...
 
ESA > Join & Share > Forums > Toolbox Forum > Information missing in Toolbox plugin installation for Eclipse Documentation

Toolbox Forum

Help

Show posts:
Jump to forum:

Information missing in Toolbox plugin installation for Eclipse Documentation

Important information missing in the documentation when installing the Toolbox DE:
-Eclipse version to be used is 3.2.2 and it can be downloaded from here.

-When installing the Toolbox plug-in select also Callisto Discovery site together with Toolbox 7.1. Selecting just the Toolbox Plug-in shows a message that other dependencies are missing. Choose "Select required" and update.


-In linux, Eclipse 3.2.2 may crash on startup with a JVM error about mozilla-gtk:
JVM terminated. Exit code=127
/usr/bin/java
-Xms40m
-Xmx256m
-Dosgi.sharedConfiguration.area=/usr/lib/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch ppc
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata 17800b
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-Dosgi.sharedConfiguration.area=/usr/lib/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
This is a documented bug (https://bugs.eclipse.org/bugs/show_bug.cgi?id=174547)
Try export MOZILLA_FIVE_HOME="" or the provided patch.


Re: Information missing in Toolbox plugin installation for Eclipse Documentation

I've just solved the problem. Only thing that I actually had to do is to unemerge "net-libs/xulrunner" package.

I hope this solution can be useful for someone else. And yes, information from the topic probably should be used in Toolbox FAQ.



Re: Information missing in Toolbox plugin installation for Eclipse

Hello Carlos,

> Important issues when installing the Toolbox DE:
> -Eclipse version to be used is 3.2.2 and it can be downloaded from here.

That's not an issue. The plugin has been specifically developed for such Eclipse version. The only issue i see is that the documentation doesn't describe the requirements in depth.

> -When installing the Toolbox plug-in select also Callisto Discovery site together with Toolbox 7.1. Selecting just the Toolbox Plug-in shows a message that other dependencies are missing. Choose "Select required" and update.

That's a normal behaviour in Eclipse. Again, the documentation may be not clear.

> -In linux, Eclipse crashes on startup with a JVM error about mozilla-gtk. Do export MOZILLA_FIVE_HOME=""

Some linux distros have a GNU JVM installed by default. Please execute "java -version" in a shell an check that you have the SUN Java virtual machine installed.

Kind regards,
Toolbox Support Team


Re: Re: Information missing in Toolbox plugin installation for Eclipse

> > -In linux, Eclipse crashes on startup with a JVM error about mozilla-gtk. Do export MOZILLA_FIVE_HOME=""
>
> Some linux distros have a GNU JVM installed by default. Please execute "java -version" in a shell an check that you have the SUN Java virtual machine installed.

I got the same problem having sun-jdk 1.6.0_17, so java vendor isn't the cause...
...but solution provided by Carlos doesn't solve the problem for me anyway.


Information missing in Toolbox plugin installation for Eclipse

> > > -In linux, Eclipse crashes on startup with a JVM error about mozilla-gtk. Do export MOZILLA_FIVE_HOME=""
> >
> > Some linux distros have a GNU JVM installed by default. Please execute "java -version" in a shell an check that you have the SUN Java virtual machine installed.
>
> I got the same problem having sun-jdk 1.6.0_17, so java vendor isn't the cause...
> ...but solution provided by Carlos doesn't solve the problem for me anyway.

I guess it depends also in Linux distribution. Have a look at http://bugs.gentoo.org/259579 to see how other people are handling the issue.


Re: Information missing in Toolbox plugin installation for Eclipse

Well, anyway...
MOZILLA_FIVE_HOME=""
MOZILLA_FIVE_HOME=/usr/lib/mozilla
MOZILLA_FIVE_HOME=/usr/lib/mozilla-firefox
MOZILLA_FIVE_HOME=/usr/lib/xulrunner-1.9.1
And any other "export" stuff doesn't work.

Probably it depends on Firefox version? I've tried 2.0.0.19 and 3.5.6.
Btw, I'm running uder Calculate Linux Desktop 10 x86 (Gentoo-based distribution).



Show posts:
Jump to forum: